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1 Introduction to Polyspace® Products for Verifying Ada Code

Product Overview

In this section...

“Overview of Polyspace Verification” on page 1-2

“The Value of Polyspace Verification” on page 1-2

Overview of Polyspace Verification
Polyspace® products verify C, C++, and Ada code by detecting run-time errors
before code is compiled and executed. Polyspace verification uses formal
methods not only to detect errors, but to prove mathematically that certain
classes of run-time errors do not exist.

To verify the source code, you set up verification parameters in a project, run
the verification, and review the results. A graphical user interface helps you
to efficiently review verification results. Results are color-coded:

• Green – Indicates code that never has an error.

• Red – Indicates code that always has an error.

• Gray – Indicates unreachable code.

• Orange – Indicates unproven code (code that might have an error).

The color-coding helps you to quickly identify errors and find the exact
location of an error in the source code. After you fix errors, you can easily run
the verification again.

The Value of Polyspace Verification
Polyspace verification can help you to:

• “Ensure Software Reliability” on page 1-3

• “Decrease Development Time” on page 1-3

• “Improve Development Process” on page 1-4
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Product Overview

Ensure Software Reliability
Polyspace software ensures the reliability of your Ada applications by proving
code correctness and identifying run-time errors. Using advanced verification
techniques, Polyspace software performs an exhaustive verification of your
source code.

Because Polyspace software verifies all possible executions of your code, it
can identify code that:

• Never has an error

• Always has an error

• Is unreachable

• Might have an error

With this information, you can be confident that you know how much of your
code is run-time error free, and you can improve the reliability of your code
by fixing the errors.

Decrease Development Time
Polyspace software reduces development time by automating the verification
process and helping you to efficiently review verification results. You can use
it at any point in the development process. However, using it early in coding
phases allows you to find errors when they are less costly to fix.

You use Polyspace software to verify Ada source code before compile time.
To verify the source code, you set up verification parameters in a project,
run the verification, and review the results. This process takes significantly
less time than using manual methods or tools that require you to modify
code or run test cases.

Color-coding of results helps you to quickly identify errors. You will spend
less time debugging because you can see the exact location of an error in the
source code. After you fix errors, you can easily run the verification again.

Using Polyspace verification software helps you to use your time effectively.
Because you know which parts of your code are error-free, you can focus on
the code that has definite errors or might have errors.
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1 Introduction to Polyspace® Products for Verifying Ada Code

Reviewing the code that might have errors (orange code) can be
time-consuming, but Polyspace software helps you with the review process.
You can use filters to focus on certain types of errors or you can allow the
software to identify the code that you should review.

Improve Development Process
Polyspace software makes it easy to share verification parameters and
results, allowing the development team to work together to improve product
reliability. Once verification parameters have been set up, developers can
reuse them for other packages in the same application.

Polyspace verification software supports code verification throughout the
development process:

• An individual developer can find and fix run-time errors during the initial
coding phase.

• Quality assurance can check overall reliability of an application.

• Managers can monitor application reliability by generating reports from
the verification results.
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Product Components

Product Components

In this section...

“Polyspace Products for Ada” on page 1-5

“Polyspace Verification Environment” on page 1-5

“Other Polyspace Components” on page 1-7

Polyspace Products for Ada
The Polyspace products for verifying Ada code are:

Polyspace® Client™ for Ada
Polyspace® Server™ for Ada

Polyspace Client for Ada software is the management and visualization tool of
Polyspace products. You use it to submit jobs for execution by the Polyspace
Server, and to review verification results.

Polyspace Server for Ada software is the computational engine of Polyspace
products. You use it to run jobs posted by Polyspace clients, and to manage
multiple servers and queues.

Polyspace Verification Environment
The Polyspace verification environment (PVE) is the graphical user interface
of the Polyspace Client for Ada software. You use the Polyspace verification
environment to create Polyspace projects, launch verifications, and review
verification results.

For Ada verification, you use two perspectives of the Polyspace verification
environment:

• “Project Manager Perspective” on page 1-6

• “Run-Time Checks Perspective” on page 1-6

1-5



1 Introduction to Polyspace® Products for Verifying Ada Code

Project Manager Perspective
The Project Manager perspective allows you to create projects, set verification
parameters, and launch verifications.

You use the Project Manager perspective in the tutorial in Chapter 2, “Setting
Up a Polyspace Project”.

Run-Time Checks Perspective
The Run-Time Checks perspective allows you to review verification results,
comment individual checks, and track review progress.
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You use the Run-Time Checks perspective in the tutorial in Chapter 4,
“Reviewing Verification Results”.

Other Polyspace Components
In addition to the Polyspace verification environment, Polyspace products
provide several other components to manage verifications, improve
productivity, and track software quality. These components include:

• Polyspace Queue Manager Interface (Spooler)

• Polyspace in One Click

• Polyspace Metrics Web Interface

1-7
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Polyspace Queue Manager Interface (Polyspace Spooler)
The Polyspace Queue Manager (also called the Polyspace Spooler) is the
graphical user interface of the Polyspace Server for Ada software. You use the
Polyspace Queue Manager Interface to move jobs within the queue, remove
jobs, monitor the progress of individual verifications, and download results.

You use the Polyspace Queue Manager in the tutorial “Launching Server
Verification from Project Manager” on page 3-6.

Polyspace in One Click
Polyspace in One Click is a convenient way to verify multiple files using the
same set of options.

After creating a project with the options you want, you can use Polyspace in
One Click to designate that project as the active project, and then send source
files to Polyspace software for verification with a single mouse click.

You use Polyspace in One Click in the tutorial “Using Polyspace In One Click
to Launch Verification” on page 3-15.

Polyspace Metrics Web Interface
Polyspace Metrics is a web-based tool for software development managers,
quality assurance engineers, and software developers. Polyspace Metrics
allows you to evaluate software quality metrics, and monitor changes in code
metrics and run-time checks through the lifecycle of a project.

For information on using Polyspace Metrics, see “Software Quality with
Polyspace Metrics” in the Polyspace Products for Ada User’s Guide.
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Installing Polyspace Products

In this section...

“Finding the Installation Instructions” on page 1-9

“Obtaining Licenses for Polyspace® Client for Ada and Polyspace® Server
for Ada Products” on page 1-9

Finding the Installation Instructions
The tutorials in this guide require both Polyspace Client for Ada and
Polyspace Server for Ada. Instructions for installing Polyspace products are
in the Polyspace Installation Guide. Before running Polyspace products, you
must also obtain and install the necessary licenses.

Obtaining Licenses for Polyspace Client for Ada and
Polyspace Server for Ada Products
See “Polyspace License Installation” in the Polyspace Installation Guide for
information about obtaining and installing licenses for Polyspace products.
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Working with Polyspace Software

In this section...

“Basic Workflow” on page 1-10

“The Workflow in This Guide” on page 1-11

Basic Workflow
The basic workflow for using Polyspace software to verify Ada source code is:

In this workflow, you:

1 Use the Project Manager perspective to set up a project file.

2 Verify code on a server or client.

You can use the Project Manager perspective to start the verification or
you can select files from a Microsoft® Windows® folder and send them to
Polyspace software for verification. For verifications that run on a server,
you can use the Polyspace Queue Manager Interface (Polyspace Spooler) to
manage the verifications and download the results to a client.

3 Use the Run-Time Checks perspective to review verification results.
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The Workflow in This Guide
The tutorials in this guide take you through the basic workflow, including the
different options for running verifications. The workflow that you will follow
in this guide is:

In this workflow, you will:

1 Create a new project that you can use for the other steps in the workflow.

This step is in the tutorial Chapter 2, “Setting Up a Polyspace Project”.

2 Verify a single package using demo Ada source code.

This step is in the tutorial Chapter 3, “Running a Verification”. In this
tutorial, you will verify the same package using three different methods
for running a verification. You will:

• Use the Project Manager perspective to start a verification that runs
on a server.

• Use Polyspace In One Click to start a verification that runs on a server.

• Use the Project Manager perspective to start a verification that runs
on a client.

3 Review the verification results.
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This step is in the tutorial Chapter 4, “Reviewing Verification Results”.
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Learning More

In this section...

“Product Help” on page 1-13

“MathWorks Online” on page 1-13

Product Help
To access the help that came with your installation, select Help > Help or
click the Help icon in the Polyspace window.

To access the online documentation for Polyspace products, go to:

/www.mathworks.com/access/helpdesk/help/toolbox/polyspace/polyspace.html

MathWorks Online
For additional information and support, see:

www.mathworks.com/products/polyspace
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Related Products

In this section...

“Polyspace Products for Verifying C/C++ Code” on page 1-14

“Polyspace Products for Linking to Models” on page 1-14

Polyspace Products for Verifying C/C++ Code
For information about Polyspace products that verify C/C++ code, see the
following:

http://www.mathworks.com/products/polyspaceclientc/

http://www.mathworks.com/products/polyspaceserverc/

Polyspace Products for Linking to Models
For information about Polyspace products that link to models, see the
following:

http://www.mathworks.com/products/polyspacemodelsl/

http://www.mathworks.com/products/polyspaceumlrh/
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2 Setting Up a Polyspace® Project

About the Setting Up a Project Tutorial

In this section...

“Overview” on page 2-2

“Example Files” on page 2-2

Overview
You must have a project file before you can run a Polyspace verification of
your source code. In this tutorial, you will create a project that you can use to
run verifications in later tutorials.

Example Files
In this tutorial, you will verify the package example.adb that comes with the
Polyspace installation CD. You can learn more about the files and folders
required for this tutorial in “Preparing Project Folders” on page 2-3.
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Creating a New Project

Creating a New Project

In this section...

“What Is a Project?” on page 2-3

“Preparing Project Folders” on page 2-3

“Opening the Polyspace Verification Environment” on page 2-4

“Creating a New Project to Verify an Ada Package” on page 2-7

What Is a Project?
In Polyspace software, a project is a named set of parameters for verification
of your software project’s source files. A project includes:

• Source files

• Include folders

• Analysis options

• One or more Verifications, each of which include:

- Source (specific versions of source files used in the verification)

- Configuration (specific set of analysis options used for the verification)

- Verification results

You can create your own project or use an existing one. You can create and
modify a project using the Project Manager perspective.

In this tutorial, you create a new project and save it as a configuration file
(.cfg).

Preparing Project Folders
Before you start verifying Ada code with Polyspace software, you must know
the locations of the Ada source package and any other specifications upon
which it may depend either directly or indirectly. You must also know where
you want to store the verification results.
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2 Setting Up a Polyspace® Project

For each project, you decide where to store source files and results. For
example, you can create a project folder and then create separate folders for
the source files, include files, and results within the project folder.

For this tutorial, prepare a project folder as follows:

1 Create a project folder named polyspace_project.

2 Open polyspace_project, and create the following folders:

• sources

• includes

• results

3 Copy the file example.adb and example.ads from

Install_folder\Examples\Demo_Ada_Single-File\sources

to

polyspace_project\sources

where Install_folder is the installation folder.

4 Copy all files from

Install_folder\Examples\Demo_Ada_Single-File\sources

to

polyspace_project\includes.

Opening the Polyspace Verification Environment
Use the Polyspace verification environment to create projects, start
verifications, and review verification results.

To open the Polyspace verification environment:

1 Double-click the Polyspace icon.
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Creating a New Project

2 If you have both Polyspace Client for C/C++ and Polyspace Client for Ada
products on your system, the PolySpace Language Selection dialog box
opens.

• Select PolySpace for Ada, and click OK.

The Polyspace verification environment opens.
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By default, the Polyspace Verification Environment displays the Project
Manager perspective. The Project Manager perspective has three main
sections.

Use this
section...

For...

Project
Browser
(upper-left)

Specifying:
• Source files

• Include folders

• Results folder

Configuration
(upper-right)

Specifying analysis options

Output
(lower-right)

Monitoring the progress of a verification, and viewing
status, log messages, and general verification statistics.
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Creating a New Project

You can resize or hide any of these sections. You learn more about the Project
Manager perspective later in this tutorial.

Creating a New Project to Verify an Ada Package
You must have a project, saved with file type .cfg, to run a verification. In
this part of the tutorial, you create a new project to verify example.adb.

You create a new project by:

• “Opening a New project” on page 2-7

• “Specifying the Source Files and Include Folders” on page 2-9

• “Specifying the Analysis Options” on page 2-11

• “Specifying Source Files to Verify” on page 2-12

• “Saving the Project” on page 2-13

Opening a New project
To open a new project for verifying example.adb:

1 Select File > New Project.

The PolySpace Project: Define Properties dialog box appears:
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2 Setting Up a Polyspace® Project

2 In the Project name field, enter example_project.

3 Clear the Default location check box.

Note Clearing the Default location check box allows you to specify
the location of your project files. In this tutorial, you change the default
location to the project folder that you created in “Preparing Project Folders”
on page 2-3. Changing the default location makes it easier to specify source
files and include folders.

4 In the Location field, enter or navigate to the project folder that you
created earlier.

In this example, the project folder is C:\PolySpace\polyspace_project.

5 Under Project language, click Ada95.

6 Click Finish. The example_project opens in the Polyspace verification
environment.
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Creating a New Project

Specifying the Source Files and Include Folders
To specify the source files and include folders for the verification of
example.adb:

1 In Project Browser, select the Source folder.

2 Click the Add source icon in the upper left the Project Browser.

.The PolySpace Project: Add Source Files and Include Folders dialog box
appears.
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2 Setting Up a Polyspace® Project

3 The project folder polyspace_project should appear in the Look in
drop-down box. If it does not, navigate to that folder.

4 Select the folder sources. Then click Add source.

The files, example.adb and example.ads, appear in the Source tree for
example_project.

5 Select the includes folder. Then click Add Include.

The includes folder appears in the Include tree for example_project.

6 Click Finish to apply the changes and close the dialog box.

The Project Browser now looks like the following:
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Specifying the Analysis Options
The analysis options in the upper-right section of the Project Manager
perspective include parameters that Polyspace software uses during the
verification process. For more information about analysis options, see
“Options Description” in the Polyspace Products for Ada Reference.

To specify the analysis options for this tutorial:

1 Expand the Target/Compilation section.

2 From the Operating system target for Standard Libraries
compatibility drop-down menu, select no-predefined-OS.

3 Keep the default values for all other options.

The analysis options now look like this.
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Specifying Source Files to Verify
Before you can launch a verification, you must specify the files in the project
that you want to verify. In example_project, there are two files to verify.

To specify source files for a verification:

1 In the Project Browser Source tree, right-click the folder
example_project[Ada 95] > Source > sources, which contains the
source files example.adb and example.ads.

2 From the context menu, select Copy Source File to > Verification_(1).

The source files example.adb and example.ads appear in the Source tree
of Verification_(1).
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Saving the Project
To save the project, select File > Save project.
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3 Running a Verification

About This Tutorial

In this section...

“Overview” on page 3-2

“Before You Start” on page 3-3

Overview
Once you have created the project example.cfg as described in “Creating a
New Project” on page 2-3, you can run the verification.

You can run a verification on a server or a client.

Use... For...

Server • Best performance

• Large files (more than 800 lines of code including comments)

• Multitasking

Client • An alternative to the server when the server is busy

• Small files with no multitasking

Note Verification on a client takes more time. You might
not be able to use your client computer when a verification is
running on it.

You can start a verification using either the Project Manager or Polyspace In
One Click. With either method, the verification can run on a server or a client.
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Use... For...

Project Manager A basic way to start a verification.

You specify the source files in the project file.
With the project file open, you click a button to
start the verification.

Polyspace In One Click A convenient way to start the verification of
several files which use the same verification
options.

Once you specify the project file containing the
verification options, you specify the source files
by selecting them from a Microsoft Windows
folder. You start the verification by sending the
selected files to Polyspace software.

In this tutorial, you learn how to run a verification on a server and on a
client, and you learn how to start a verification using the Project Manager
and Polyspace In One Click. You verify the package example.adb three times
using a different method each time. You use:

1 Project Manager to start a verification that runs on a server.

2 Polyspace In One Click to start a verification that runs on a server.

3 Project Manager to start a verification that runs on a client.

Each verification stores the same results in your project. You review these
results in the tutorial Chapter 4, “Reviewing Verification Results”.

Before You Start
Before you start this tutorial, you must complete Chapter 2, “Setting Up a
Polyspace Project”. You use the folders and project file, example.cfg, from
that tutorial to run the verifications.
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Preparing for Verification

In this section...

“Opening the Project” on page 3-4

“Specifying Source Files to Verify” on page 3-4

Opening the Project
To run a verification, you must have an open project file. For this tutorial, you
use the project file example.cfg that you created in Chapter 2, “Setting Up a
Polyspace Project”. Open example.cfg if it is not already open.

To open example.cfg:

1 If the Polyspace verification environment is not already open, double-click
the Polyspace icon.

2 Select File > Open project.

The Open a PolySpace project file dialog box opens.

3 In Look in, navigate to polyspace_project.

4 Select example_project.cfg.

5 Click Open to open the file and close the dialog box.

Specifying Source Files to Verify
Each Polyspace project can contain multiple verifications. Each of these
verifications analyze a specific set of source files using a specific set of
analysis options.

Therefore, before you can launch a verification, you must specify which files in
your project you want to verify. In the example_project used in this tutorial,
there is only one file to verify.

To copy source files to a verification:
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1 In the Project Browser Source tree, right-click the folder
example_project[Ada 95] > Source > sources, which contains the
source files example.adb and example.ads.

2 From the context menu, select Copy Source File to > Verification_(1).

The source files example.adb and example.ads appear in the Source tree
of Verification_(1).
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Launching Server Verification from Project Manager

In this section...

“Starting the Verification” on page 3-6

“Monitoring the Progress of the Verification” on page 3-7

“Removing Verification Results from the Server” on page 3-11

“Troubleshooting a Failed Verification” on page 3-12

Starting the Verification
In this part of the tutorial, you run the verification on a server.

To start a verification that runs on a server:

1 In the Configuration view, under Analysis options > General, select
the Send to Polyspace Server check box.

2 Click the Run button on the Project Manager toolbar.

Note If you see the message Verification process failed, click OK
and go to “Troubleshooting a Failed Verification” on page 3-12.

The verification has three main phases:

a Checking syntax and semantics (the compile phase). Because Polyspace
software is independent of any particular Ada compiler, it ensures that
your code is portable, maintainable, and complies with Ada standards.

b Generating a main if it does not find a main and the Generate a Main
option is selected. For more information about generating a main, see
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“Generate a main” in the “Options Description” chapter of Polyspace
Products for Ada Reference.

c Analyzing the code for run-time errors and generating color-coded
diagnostics.

The compile phase of the verification runs on the client. When the compile
phase finishes:

• You see the message queued on server at the bottom of the Project
Manager perspective. This message indicates that the part of the
verification that takes place on the client is complete. The rest of the
verification runs on the server.

• A message in Output Summary gives you the identification number
(Analysis ID) for the verification.

3 For information on any message in the log, click the message.

Monitoring the Progress of the Verification
There are two ways to monitor the progress of a verification:

• Using the Project Manager – allows you to follow the progress of the
verifications you submitted to the server, as well as client verifications.

• Using the Queue Manager (Spooler) – allows you to follow the progress
of any verification job in the server queue.

Monitoring Progress Using Project Manager
You can monitor the progress of your verification by viewing the progress
monitor and logs at the bottom of the Project Manager perspective.

The progress monitor highlights the current phase in blue and displays the
amount of time and completion percentage for that phase.
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The logs report additional information about the progress of the verification.
To view a log, click the button for that log. The information appears in the
log display area at the bottom of the Project Manager window. Follow the
next steps to view the logs:

1 Click the Output Summary tab to display compile phase messages and
errors. You can search the log by entering search terms in the Search
box and clicking the left arrow to search backward or the right arrow to
search forward.

2 Click the Verification Statistics tab to display statistics, such as analysis
options, stubbed functions, and the verification checks performed.

3 Click the Refresh button to update the display as the verification
progresses.

4 Click the Full Log tab to display messages, errors, and statistics for all
phases of the verification. You can search the log by entering search terms
in the Search box and clicking the left arrow to search backward or the
right arrow to search forward.

Monitoring Progress Using Queue Manager
You monitor the progress of the verification using the Polyspace Queue
Manager (also called the Spooler).

To monitor the verification of Example_Project:

1 In the Run-Time Checks perspective toolbar, click the Polyspace Queue

Manager icon . The Polyspace Queue Manager Interface opens.
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2 Point anywhere in the row for ID 1.

3 Right-click to open the context menu for this verification.

4 Select View log file.

A window opens displaying the last one-hundred lines of the verification.
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5 Click Close to close the window.

6 Select Follow Progress from the context menu. The Progress Monitor
opens.

You can monitor the progress of the verification by watching the progress
bar and viewing the logs at the bottom of the window. The progress monitor
highlights the current phase in blue and displays the amount of time and
completion percentage for that phase.

The logs report additional information about the progress of the verification.
To view a log, click the button for that log. The information appears in the
log display area at the bottom of the Project Manager window. Follow the
next steps to view the logs:

• Click the Output Summary tab to display compile phase messages and
errors. You can search the log by entering search terms in the Search
box and clicking the left arrow to search backward or the right arrow to
search forward.

• Click the Verification Statistics tab to display statistics, such
as analysis options, stubbed functions, and the verification checks
performed.

• Click the Refresh button to update the display as the verification
progresses.

• Click the Full Log tab to display messages, errors, and statistics for all
phases of the verification. You can search the log by entering search
terms in the Search box and clicking the left arrow to search backward
or the right arrow to search forward.

7 Select File > Quit to close the progress window.

8 Wait for the verification to finish.

When the verification is complete, the status in the Polyspace Queue
Manager Interface changes from running to completed.
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Removing Verification Results from the Server
At the end of a server verification, the server automatically downloads
verification results to the results folder specified in the project. You do not
need to manually download your results.

Note You can manually download verification results to another location on
your client system, or to other client systems.

Verification results remain on the server until you remove them. Once your
results have been downloaded to the client, you can remove them from the
server queue.

To remove your results from the server:

1 In the Polyspace Queue Manager Interface, right-click the verification, and
select Remove From Queue. A dialog box opens requiring confirmation
that you want to remove the verification from the queue.

2 Click Yes.

Note To download the results and remove the verification from the queue,
right-click the verification and select Download Results And Remove
From Queue. If you download results before the verification is complete,
you get partial results and the verification continues.

3 Select Operations > Exit to close the Polyspace Queue Manager Interface.
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Once the results are on your client, you can review them using the Run-Time
Checks perspective. You review the results from the verification in Chapter
4, “Reviewing Verification Results”.

Troubleshooting a Failed Verification
When you see a message that the verification failed, it indicates that
Polyspace software could not perform the verification. The following sections
present some possible reasons for a failed verification.

Hardware Does Not Meet Requirements
The verification fails if your computer does not have the minimal hardware
requirements. For information about the hardware requirements, see

www.mathworks.com/products/polyspaceclientada/requirements.html.

To determine if this is the cause of the failed verification, search the log for
the message:

Errors found when verifying host configuration.

You can:

• Upgrade your computer to meet the minimal requirements.

• Select the Continue with current configuration option in the General
section of the Analysis options and run the verification again.

You Did Not Specify the Location of Included Files
If you see a message in the log, such as the following, either the files are
missing or you did not specify the location of included files.

Verifier found an error in example.adb:23:14: "runtime_error
(spec)" depends on "types (spec)"

For information on how to specify the location of include files, see “Creating a
New Project to Verify an Ada Package” on page 2-7.
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Polyspace Software Cannot Find the Server
If you see the following message in the log, Polyspace software cannot find
the server.

Error: Unknown host :

Polyspace software uses information in the preferences to locate the server.
To find the server information in the preferences:

1 Select Options > Preferences.

2 Select the Server Configuration tab.
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By default, Polyspace software automatically finds the server. You can
specify the server by selecting Use the following server and port and
providing the server name and port. For information about setting up a
server, see the Polyspace Installation Guide.
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Using Polyspace In One Click to Launch Verification

In this section...

“Overview of Polyspace In One Click” on page 3-15

“Setting the Active Project” on page 3-15

“Sending the Files to Polyspace Software” on page 3-17

Overview of Polyspace In One Click
In a Microsoft Windows environment, Polyspace software provides a
convenient way to streamline your work when you want to verify several
packages using the same set of options. Once you have set up a project file
that has the options you want, you designate that project as the active project,
and then send the source files to Polyspace software for verification. You do
not have to update the project with source file information. This process is
called Polyspace In One Click.

In this part of the tutorial, using Polyspace In One Click, you learn how to:

1 Set the active project.

2 Send source files to Polyspace software for verification.

Setting the Active Project
The active project is the project that Polyspace In One Click uses to verify the
packages that you select. Once you have set an active project, it remains
active until you change the active project. Polyspace software uses the
analysis options from the project; it does not use the source files or results
folder from the project.

To set the active project:

1 Right-click the Polyspace In One Click icon in the taskbar area of your
Windows desktop:
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The context menu appears.

2 Select Set active project > Browse from the menu.

The Please set an active project dialog box appears:

3 Navigate to polyspace_project.

4 Select example_project.cfg.
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5 Click Open to apply the changes and close the dialog box.

Sending the Files to Polyspace Software
You can send several packages to Polyspace software for verification. For this
tutorial, you send one package, example.adb.

To send example.adb to Polyspace software for verification:

1 Navigate to the folder polyspace_project\sources.

2 Select the files example.adb and example.ads.

3 Right-click the file example.adb.

The context menu appears.

4 Select Send To > PolySpace.

The Polyspace basic settings dialog box appears.
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5 Make sure that Results folder is polyspace_project.

6 Select the Send to Polyspace Server option if it is not already selected.

7 Leave the default values for the other parameters.

Click Start.

The verification log appears.
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The compile phase of the verification runs on the client. When the compile
phase completes:

• You see the message:

End of PolySpace Verifier analysis

• A message in the log area tells you that the verification was transferred to
the server and gives you the identification number (Analysis ID) for the
verification. For this verification, the identification number is 1.

• Monitor the verification using the Spooler. For information on using the
Spooler to monitor a verification on a server, see “Monitoring the Progress
of the Verification” on page 3-7.
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• When the verification completes, download the results to
polyspace_project\results. For information on downloading results
from a server to a client, see “Removing Verification Results from the
Server” on page 3-11

You review the results in Chapter 4, “Reviewing Verification Results”.
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Launching Client Verification from Project Manager

In this section...

“Starting the Verification” on page 3-21

“Monitoring the Progress of the Verification” on page 3-22

“Completing Verification” on page 3-23

“Stopping the Verification” on page 3-24

Starting the Verification
For the best performance, run verifications on a server. If the server is busy
or you want to verify a small package, you can run a verification on a client.

Note Because a verification on a client can process only a limited number
of variable assignments and function calls, the source code should have no
more than 800 lines of code.

To start a verification that runs on a client:

1 Open the project file example_project.cfg if it is not already open.

For information about opening a project file, see “Preparing for Verification”
on page 3-4.

2 In the Configuration pane, under Analysis options > General, clear
the Send to Polyspace Server check box.

3 If you see a warning that multitasking is not available when you run
a verification on the client, click OK to continue and close the message
box. This warning only appears when you clear the Send to Polyspace
Server check box.

4 Click the Run button on the Project Manager toolbar.
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5 If you see a caution that Polyspace software will remove existing results
from the results folder, click Yes to continue and close the message dialog
box.

The Output Summary and Progress Monitor windows become active,
allowing you to monitor the progress of the verification

Note If you see the message Verification process failed, click OK and
go to “Troubleshooting a Failed Verification” on page 3-12.

Monitoring the Progress of the Verification
You can monitor the progress of the verification by viewing the progress
monitor and logs at the bottom of the Project Manager perspective.

The progress bar highlights the current phase in blue and displays the
amount of time and completion percentage for that phase.

The logs report additional information about the progress of the verification.
To view a log, click the corresponding tab. The information appears in the
log display area at the bottom of the Project Manager perspective. Follow the
next steps to view the logs:

1 Click the Output Summary tab to display compile phase messages and
errors. You can search the log by entering search terms in the Search
field and clicking the left arrow to search backward or the right arrow to
search forward.

3-22



Launching Client Verification from Project Manager

2 Click the Verification Statistics tab to display statistics, such as analysis
options, stubbed functions, and the verification checks performed.

Click the refresh button

to update the display as the verification progresses.

3 Click the Full Log tab to display messages, errors, and statistics for all
phases of the verification.

You can search the full log by entering a search term in the Search in the
log box and clicking the left arrow to search backward or the right arrow to
search forward.

Completing Verification
When the verification finishes, the message Verification Completed
appears at the bottom of the Project Manager window, and the results appear
in the Project Browser.
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In the tutorial Chapter 4, “Reviewing Verification Results”, you open the
Run-Time Checks perspective and review the verification results.

Stopping the Verification
You can stop the verification before it is complete. If you stop the verification,
results are incomplete. If you start another verification, the verification starts
from the beginning.

To stop a verification:

1 Click the Stop button on the Project Manager toolbar.

A warning dialog box opens.

2 Click Yes.

The verification stops and the message Verification process stopped
appears.

3 Click OK to close the Message dialog box.

Note Closing the Polyspace verification environment window does not stop
the verification. To resume display of the verification progress, start the
Polyspace software and open the project.
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About the Reviewing Verification Results Tutorial

In this section...

“Overview” on page 4-2

“Before You Start” on page 4-2

Overview
In the previous tutorial, Chapter 3, “Running a Verification”, you completed
a verification of the package example.adb. In this tutorial, you explore the
verification results.

The Polyspace verification environment contains a Run-Time Checks
perspective that you use to review results. In this tutorial, you learn:

1 How to use the Run-Time Checks perspective, including how to:

• Open the Run-Time Checks perspective and view verification results.

• Explore results in expert mode.

• Explore results in assistant mode.

• Generate reports.

2 How to interpret the color-coding that Polyspace software uses to identify
the severity of an error.

3 How to find the location of an error in the source code.

Before You Start
Before starting this tutorial, complete the tutorial Chapter 3, “Running a
Verification”. In this tutorial, you use the verification results stored in this
file:

polyspace_project\Verification_(1)\Result_(1)\RTE_px_example_project_

LAST_RESULTS.rte
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Opening Verification Results

In this section...

“Opening Run-Time Checks Perspective” on page 4-3

“Opening Verification Results” on page 4-3

Opening Run-Time Checks Perspective
Use the Run-Time Checks perspective to review verification results. To open
the Run-Time Checks perspective, on the Polyspace verification environment

toolbar, click the Run Time Checks button .

Opening Verification Results
To open the verification results:

1 Select File > Open Result.

2 In the Please select a file dialog box, navigate to
polyspace_project\Verification_(1)\Result_(1) and select the file
RTE_px_example_project_LAST_RESULTS.rte.

3 Click Open.

The results appear in the Run-Time Checks perspective.
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Exploring Run-Time Checks Perspective

In this section...

“Overview” on page 4-4

“Reviewing Procedural Entities” on page 4-5

Overview
The Run-Time Checks perspective looks like this.
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The Run-Time Checks perspective has six sections below the toolbar. Each
section provides a different view of the results. The following table describes
these views.

This view... Displays...

Procedural entities Diagnostics (checks) for each file and
function in the project

Source code Source code for a selected check in
the procedural entities view

Coding review Statistics about the review progress
for checks with the same type and
category as the selected check

Selected check Details about the selected check

Variables Information about the global
variables declared in the source code

Note The file that you use in
this tutorial does not have global
variables.

Call tree Tree structure of function calls

You can resize or hide any of these sections. You learn more about the
Run-Time Checks perspective later in this tutorial.

Reviewing Procedural Entities
The procedural entities view, on the left side of the Run-Time Checks
perspective, displays a table with information about the diagnostics for each
file in the project. The procedural entities view is also called the Run-Time
Checks view. When you first open the results file from the verification of
example.adb, you see the following procedural entities view.
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If you place the cursor over Procedural entities and right-click, you can
select other columns to display, for example, Classification.

The package RUNTIME_ERROR is red because its contains at least one definite
run-time error. Polyspace software assigns each package the color of the
most severe error found in that package. Note that the other entities
displayed for the example project are simply black. This indicates that they
contain specifications that were used for the analysis. The first column of
the Procedural entities view names the procedural entity (the package or
function). The following table describes some of the other columns in the
procedural entities view.
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Column
Heading

Indicates

Number of red checks (operations where an error always
occurs)

Number of gray checks (unreachable code)

Number of orange checks (warnings for operations where
an error might occur)

Number of green checks (operations where an error never
occurs)

Selectivity of the verification (percentage of checks that are
not orange)
This is an indication of the level of proof.

Tip If you see three dots in place of a heading, , resize the column until you
see the heading. Resize the procedural entities view to see additional columns.

What you select in the procedural entities view determines what is displayed
in the other views. In the following examples, you learn how to use the views
and how they interact.
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Reviewing Results

In this section...

“Using Review Assistant” on page 4-8

“Reviewing All Checks” on page 4-8

“Reviewing Example Checks” on page 4-12

“Filtering Checks” on page 4-15

Using Review Assistant
You can use the review Assistant on the Run-Time Checks toolbar to facilitate
your review of run-time checks.

Use the Assistant slider to select a mode (1, 2, or 3). Each mode corresponds
to a set of criteria specified by a configuration set. By default, when you open
a results file, the software opens the Run-Time Checks perspective with the
slide at 1 and the Methodology for Ada configuration selected.

Polyspace software uses the configuration set to choose checks for review. You
can create new configuration sets by using the Assistant configuration
tab in the Polyspace Preferences dialog box. For more information, see
“Reviewing Results in Assistant Mode” on page 4-19.

To review all run-time checks, move the Assistant slider to Off . See
“Reviewing All Checks” on page 4-8.

For

Reviewing All Checks
In this part of the tutorial, you learn how to use the Run-Time Checks
perspective views to examine checks from a verification. This part of the
tutorial covers:
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• “Selecting a Check to Review” on page 4-9

• “Displaying the Calling Sequence” on page 4-11

• “Tracking Review Progress” on page 4-11

Note To see all checks in the procedural entities view, move the Assistant
slider to Off. See “Using Review Assistant” on page 4-8.

Selecting a Check to Review
In the procedural entities view, RUNTIME_ERROR is red, indicating that this
package has at least one red check. To review a red check in RUNTIME_ERROR:

1 In the procedural entities view, expand RUNTIME_ERROR.

2 Expand the red function SQUARE_ROOT.

A color-coded list of the checks performed on SQUARE_ROOT appears:

Each item in the list of checks has an acronym that identifies the type of
check and a number. For example, in EXCP.4, EXCP stands for Arithmetic
Exception. For more information about different types of checks, see
“Check Descriptions” in the Polyspace Client/Server for Ada User’s Guide.

3 Click on the red check EXCP.4.
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You see the section of source code where this error occurs, and details
about the check.

4 In Review Details, you can:

• Classify the run-time check as a defect. Select a category from the
Classification drop-down list, for example, High.

• Assign a status, for example, Fix. This action indicates to Polyspace
that you have reviewed the check

• Justify the check. For example, if you classified the check as Not a
defect, you could select the Justified check box to indicate that the
check is justified.

• Enter remarks in the Comment field, for example, defect or justification
information.
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Displaying the Calling Sequence
You can display the calling sequence that leads to the code associated with a
check. To see the calling sequence for the red EXCP.5 check in SQUARE_ROOT:

1 In the procedural entities view, expand SQUARE_ROOT.

2 Click on the red check EXCP.5.

3 In the Review Details toolbar, click the call graph button.

A window displays the call graph.

The code associated with EXCP.5 is in SQUARE_ROOT. The function MAINRTE
calls SQUARE_ROOT.

Tracking Review Progress
Review Statistics allows you to keep track of the checks that you have
reviewed.
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The Count column displays a ratio and the Progress column displays the
equivalent percentage. The first row displays the ratio of justified checks
to the total number of checks that have the same color and category as the
current check. In this example, it displays the ratio of justified red NTL
checks to total red NTL errors in the project.

The second, third, and fourth rows displays the ratio of justified checks to
total checks for red, gray, and orange checks respectively. The fifth row
displays the ratio of the number of green checks to the total number of checks,
providing an indicator of the reliability of the software.

Reviewing Example Checks
In this part of the tutorial, you learn about other types and categories of
errors by reviewing the following checks in example.adb:

• “Example: Unreachable Code” on page 4-12

• “Example: A Function with No Errors” on page 4-13

• “Example: Division by Zero” on page 4-14

Example: Unreachable Code
Unreachable code is code that never executes. Polyspace software displays
unreachable code in gray. In the following steps, you will look at an example
of unreachable code.

1 Under Procedural Entities, expand UNREACHABLE_CODE and click on the
gray ZDV.6.

The source code for this function displays in the source code view.

4-12



Reviewing Results

2 Examine the source code.

At line 190, the code Z := x / Y; is never reached because the condition x
< 0 is always false.

Example: A Function with No Errors
In the following example, Polyspace software determines, in code with a large
number of iterations, that a loop terminates and a variable does not overflow:

1 In Procedural entities, click on the green NON_INFINITE_LOOP function.

The source code for this function is displayed in the source code view.
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2 Examine the source code. The variable cur never overflows because the
loop at line 117 terminates before cur can overflow.

Example: Division by Zero
In the following example, Polyspace software detects a potential division
by zero:

1 In Procedural entities, expand RECURSION.

The source code for this function is displayed in the source code view.
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2 Examine the RECURSION function.

When RECURSION is called with depth less than zero, the code at line 70
will result in division by zero. The orange color indicates that this is a
potential error (depending on the value of depth).

Filtering Checks
You can filter the checks that you see in the Run-Time Checks perspective so
that you can focus on certain checks. Polyspace software allows you to filter
your results in several ways. You can filter by:

• Check category (ZDV, IDP, NIP, etc.)

• Color of check (gray, orange, green)
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• Justified or unjustified

• Classification

• Status

To filter checks, select one of the filter buttons in the Run-Time checks toolbar.

Tip The tooltip for a filter button tells you what filter the button is for.

Example: Filtering NIVL Checks

You can use an RTE filter to hide a given check category, such as NIVL. When
a filter is enabled, you do not see that check category.

To filter NIVL checks:

1 Expand PROCEDURE_ZDV.

PROCEDURE_ZDV has seven checks: five are green, one is gray, and one is red.

2 Click the RTE filter icon .

3 Clear the NIVL check box.

4-16



Reviewing Results

The software hides the NIVL check for PROCEDURE_ZDV.

4 Select the NIVL option to redisplay the NIVL check.

Note When you filter a check category, red checks of that category are not
hidden. For example, if you filter ZDV checks, you still see ZDV.7 under
PROCEDURE_ZDV.

Example: Filtering Green Checks

You can use a color filter to hide checks of a certain color.

To filter green checks:

1 Expand PROCEDURE_ZDV.

PROCEDURE_ZDV has eight checks: six are green, one is gray, and one is red.
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2 Click the Color filter icon .

3 Clear Green Checks.

The software hides the green checks.
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Reviewing Results in Assistant Mode

In this section...

“What Is Assistant Mode?” on page 4-19

“Switching to Assistant Mode” on page 4-19

“Selecting the Methodology and Criterion Level” on page 4-20

“Exploring Methodology for Ada” on page 4-20

“Reviewing Checks” on page 4-22

“Defining a Custom Methodology” on page 4-23

What Is Assistant Mode?
In assistant mode, Polyspace software chooses the checks for you to review
and the order in which you review them. Polyspace software presents checks
to you in this order:

1 All red checks

2 All blocks of gray checks (the first check in each unreachable function)

3 Orange checks according to the selected methodology and criterion level

You will learn about methodologies and criterion levels in “Selecting the
Methodology and Criterion Level” on page 4-20.

Switching to Assistant Mode
To switch to assistant mode:

• Move the Assistant slider to 1 in the Run-Time Checks toolbar.

The toolbar displays controls specific to assistant mode.
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The controls for this mode include:

• A menu for selecting the review methodology for orange checks.

• A slider for selecting the criterion level within that methodology.

• Arrows for navigating through the reviews.

Selecting the Methodology and Criterion Level
A methodology is a named configuration that defines the number of orange
checks, by category, that you review in assistant mode. Each methodology
has three criterion levels. Each level specifies the number of orange checks
for a given category. The levels correspond to different development phases
that have different review requirements. To select the methodology and level
for this tutorial:

1 Select Methodology for Ada from the methodology menu.

2 If the level slider is not already at 1, move the slider to level 1.

Exploring Methodology for Ada
In this part of the tutorial, you examine the configuration for Methodology
for Ada. To begin:

1 Select Options > Preferences.

The Polyspace Preferences dialog box appears.

2 Select the Assistant configuration tab.

The configuration for Methodology for Ada appears.
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On the right side of the dialog box, a table shows the number of orange
checks that you review for a given criterion and check category.

For example, the table specifies that you review ten orange ZDV checks
when you select criterion 1. The number of checks increases as you move
from criterion 1 to criterion 3, reflecting the changing review requirements
as you move through the development process.

In the lower-left part of the dialog box, the section Review threshold
criterion contains text that appears in the tooltip for the Assistant slider
on the Run-Time Checks toolbar.

For the configuration Methodology for Ada, the criterion names are:
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Criterion Name in the Tooltip

1 Fresh code

2 Unit tested

3 Code review

These names correspond to phases of the development process.

3 Click OK to close the dialog box.

Reviewing Checks
In assistant mode, you review checks in the order in which Polyspace software
presents them:

1 All red checks

2 All blocks of gray checks (the first check in each unreachable function)

3 Orange checks according to the selected methodology and criterion level

Earlier in this tutorial, you selected Methodology for Ada, criterion l. In this
part of the tutorial, you continue to review the checks for example.adb using
this methodology and criterion level. To navigate through these checks:

1 Click the forward arrow .

The software displays ZDV.7 as the current check.
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The source code view displays the source for this check. InReview Details,
you see information about this check and you can review this check.

Note You can display the calling sequence and track review progress as
you did in “Reviewing Results” on page 4-8.

2 Continue to click the forward arrow until you have reviewed all the checks.

After the last check, a dialog box appears asking if you want to start again
from the first check.

3 Click No.

Defining a Custom Methodology
You cannot change the predefined methodologies, such as Methodology for
Ada, but you can define your own methodology. In this part of the tutorial,
you learn how to create and use your own methodology.

The methodology that you create is the Methodology for Ada with one change:

1 Select Option > Preferences.

The Polyspace Preferences dialog box opens.

2 Select the Assistant configuration tab.

3 Select Add a set from the Configuration set drop-down list.
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4 In the Create a new set dialog box, enter My methodology and click
Enter to close the dialog box.

5 Under the Criterion 1 column, enter the number 1 next to ZDV . This tells
Polyspace software to select up to one orange ZDV for review.

6 Click OK to save the methodology and close the dialog box.

To use My methodology:

1 Select My methodology from the methodology menu.

2 If the level slider is not already at 1, move the slider to level 1.

3 Click the forward arrow to review the checks.

With this methodology at criterion 1, the only orange check you review
is the orange ZDV.5 in RECURSION.
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Generating Reports of Verification Results

In this section...

“Polyspace Report Generator Overview” on page 4-25

“Generating Report for example.adb” on page 4-26

Polyspace Report Generator Overview
The Polyspace Report Generator allows you to generate reports about your
verification results, using predefined report templates.

The Polyspace Report Generator provides the following report templates:

• Coding Rules Report — Provides information about compliance with
MISRA-C Coding Rules, as well as Polyspace configuration settings for
the verification.

• Developer Report— Provides information useful to developers, including
summary results, detailed lists of red, orange, and gray checks, and
Polyspace configuration settings for the verification.

• Developer with Green Checks Report— Provides the same content as
the Developer Report, but also includes a detailed list of green checks.

• Quality Report — Provides information useful to quality engineers,
including summary results, statistics about the code, graphs showing
distributions of checks per file, and Polyspace configuration settings for
the verification.

• Software Quality Objectives Report — Provides information on
software quality objectives (SQO), including code metrics, code verification
(run-time checks), and configuration settings for the verification. The code
metrics section provides the same information as the Code Metrics view of
the Polyspace Metrics web interface.

The Polyspace Report Generator allows you to generate verification reports in
the following formats:

• HTML

• PDF
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• RTF

• Microsoft Word

• XML

Note Microsoft Word format is not available on UNIX platforms. RTF format
is used instead.

Generating Report for example.adb
You can generate reports for any verification results using the Polyspace
Report Generator.

To generate a verification report:

1 Open your verification results.

2 Select Run > Run Report > Run Report.

The Run Report dialog box opens.
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3 In the Select Report Template section, select Developer.rpt.

4 In Output folder, specify a folder, for example,
polyspace_project\Verification_(1)\Result_(1)\PolySpace-Doc.

5 Select, for example, RTF from the Output format drop-down list.

6 Click Run Report.

The software creates the specified report. When report generation is
complete, the report opens.
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